PowerLite Pro G5150NL Projector

Selected FAQ

Q:
Which operating systems support the EMP Monitor software?
A:
EMP Monitor is supported by Microsoft Windows 98SE, Me, NT 4.0 SP6, 2000 (SP4), XP 32Bit (Home/Professional Edition) SP1 or later, and Vista 32.
Published: June 5, 2008

Was this helpful? Yes No Didn't Apply

Viewed FAQs

Return to Main FAQs Page