Epson Zip-100S (SCSI)

Selected FAQ

Q:
What operating systems are supported?
A:
MS-DOS 4.x or greater, DR/NOVELL DOS 6.0 or greater, Compaq DOS 3.31 or greater, Windows 3.x, and Windows 95. OS/2 version 2.0 or greater with the purchase of the optional Iomega OS/2 driver software package (OAD For OS/2 version 2.33 or greater). Macintosh System 7.0 or greater is required for full functionality and support.

Thank you for your feedback.
Was this FAQ helpful?
Yes No  
Please tell us why this FAQ was not helpful.
Note: We are unable to reply to comments submitted here.


Viewed FAQs

Return to Main FAQs Page