LQ-680Pro Impact Printer

Selected FAQ

Q:
What operating systems and workgroup environments does the LQ-680Pro support?
A:
The LQ-680Pro is compatible with Windows 3.1x, 95, 98, 2000, Me, and NT 3.51/4.0 operating systems.

Was this helpful? Yes No Didn't Apply

Viewed FAQs

Return to Main FAQs Page