Epson Stylus Color 880 Ink Jet Printer

Selected FAQ

Q:
What are the system requirements for using this printer with a Macintosh computer?
A:
Macintosh Requirements
  • An Apple® iMac™ series or Power Macintosh® G3 or G4 with USB port
  • For iMac: Mac® OS 8.5 or later (Mac OS 8.5.1 or later recommended)
  • For Power Macintosh G3 or later: Mac OS 8.5.1 or later.
    If your iMac is running OS 8.1, you need to upgrade your operating system before installing your printer software. To find out which operating system your iMac is running, select 'About This Computer' from the Apple menu.
    If you're running OS 8.5 or 8.5.1 on your iMac, Apple recommends that you install iMac Update 1.1. Download the update for your system by clicking on the "Apple - Support" link from our Third Party Contacts Page. Contact Apple if you have problems installing an update.
  • 16MB of available RAM (more recommended)
  • 50MB of free hard disk space (100MB recommended)
  • VGA display or better
  • CD-ROM or DVD drive for installing the printer software
  • A shielded USB "AB" cable up to 6.5 feet (2 meters) long. Using an improperly shielded USB cable-especially a cable more than 6.5 feet (2 meters) long-may cause the printer to malfunction.

Was this helpful? Yes No Didn't Apply

Viewed FAQs

Return to Main FAQs Page