Epson Stylus NX420 All-in-One Printer

Selected FAQ

Q:
What are the system requirements for using the product with my computer?
A:
To use your product and its software, your computer system should meet these requirements:

Windows requirements
  • Microsoft Windows 7, Windows Vista, Windows XP Professional x64 Edition, or Windows XP


  • USB 1.1 port (minimum) or USB 2.0 port (recommended) and a shielded USB "AB" cable required for a USB connection. USB port and cable are not required when connecting the product to a wireless network. However, temporary use of a USB port and cable is recommended to install the product on a wireless network.

Macintosh requirements
  • Mac OS X 10.4.11, 10.5.8, or 10.6.x


  • USB 1.1 port (minimum) or USB 2.0 port (recommended) and a shielded USB "AB" cable required for a USB connection. USB port and cable are not required when connecting the product to a wireless network. However if you're using Mac OS X 10.4 or 10.5, temporary use of a USB port and cable is recommended to install the product on a wireless network.
Updated: March 24, 2011

Was this helpful? Yes No Didn't Apply

Viewed FAQs

Return to Main FAQs Page