DC-11 Document Camera

Selected FAQ

Q:
What are the system requirements for using the document camera with my computer?
A:
See the requirements below.

Windows: Microsoft Windows 7, Windows Vista, Windows XP (Service Pack 2 or later)

Macintosh: Mac OS X 10.5 to 10.6
Published: October 13, 2010

Was this helpful? Yes No Didn't Apply

Viewed FAQs

Return to Main FAQs Page