PowerLite D6150 XGA 3LCD Projector

Selected FAQ

Q:
What are the system requirements for the software that comes with the projector?
A:
See below:





* Operation is not guaranteed in Mac OS X 10.5.0 because the Firewall settings are not set correctly when the version is updated.
Published: April 12, 2011

Was this helpful? Yes No Didn't Apply

Viewed FAQs

Return to Main FAQs Page