BrightLink 435Wi Interactive WXGA 3LCD Projector with Wall Mount

Selected FAQ

Q:
Which operating systems support the Easy Interactive Tools software?
A:
The Easy Interactive Tools software is supported by the following operating systems:

  • Software and Computer Requirements (included)


  • Easy Interactive Driver Windows 2000 SP4 or later, Windows XP SP2 or later (Home Edition/Professional), Windows Vista (All editions except for Starter 32 bit only), Windows 7 (32 or 64 bit), Mac OS X 10.3.x, 10.4.x, 10.5.x, 10.6.x, 10.7.x.

    TeamBoard Draw Windows 7 (32 or 64 bit), Windows Vista (32 or 64 bit), Windows XP SP3 (32 bit), Mac OS X 10.5 or later.

  • Educational Software Option (available)


  • RM Easiteach Windows 7 (32 or 64 bit), Windows Vista (32 or 64 bit), Windows XP SP3 (32 bit), Mac OS X 10.3.9 or later.
Published: April 7, 2012

Was this helpful? Yes No Didn't Apply

Viewed FAQs

Return to Main FAQs Page