Epson MovieMate 30s

Selected FAQ

Q:
No image appears. What should I do?
A:
Check the following:

  • Make sure Epson MovieMate is turned on (the  Power light is green and not flashing). If the Image On light is flashing green, wait for Epson MovieMate to warm up. If the Image Off light is flashing orange, wait until it stops flashing, then press the  Power button.


  • Make sure the lens cover is off.


  • The image may be off the screen. Use the quick image adjustment dials to adjust its position. See Adjusting the Picture.


  • Press the  button on Epson MovieMate or on the remote control to make sure the picture hasn’t been turned off temporarily.


  • Make sure Epson MovieMate is not tilted. Tilting it more than 5 degrees up or down may cause disc problems. Use the quick image adjustment dial to adjust the image position.


  • Make sure the region code on the DVD is 1.


  • Check the  warning light. If it is flashing orange or red, you need to replace the lamp. For instructions see Replacing the Lamp.


  • If you’re using external video equipment, check the following:


    • Make sure the external video equipment is turned on.


    • Press the  or Play button on the external equipment.


    • Make sure you don’t have cables connected to more than one video port. You can only use one connection at a time. See Viewing Video from External Devices for more information.
Published: September 28, 2006

Was this helpful? Yes No Didn't Apply

Viewed FAQs

Return to Main FAQs Page